Software für Raspberry mit TPUART Modul

Fragen und Diskussionen zu den Geräten. Sowohl Hardware als auch Software. English is welcome.
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Hi ihr beiden :)

Danke für die Antworten!
Werde das sobald möglich nachschauen, bzw. ausprobieren.

Ich verwende ETS 5 da siehts etwas anders aus....
Sollte aber ja vom Prinzip her gleich sein.

Eine PN ist unterwegs zu dir Hans ;)

Lg Michi

Tags:
jens78
Beiträge: 1
Registriert: 31. Jul 2019, 06:48

Re: Software für Raspberry mit TPUART Modul

Beitrag von jens78 »

Hallo Zusammen,

probiert doch bitte mal folgende einstellungen in der knxd.conf

KNXD_OPTS="-e 0.0.0 -E 0.0.0:8 -d -D -T -R -S -i --listen-local=/tmp/knx -b tpuarts:/dev/ttyAMA0"

mit der einstellung läuft bei mir der KNXD mit der TPUART-Selbstbau Adapter-Platine auf dem Raspberry 2B+.

Gruß
Jens
ZwergNase
Beiträge: 51
Registriert: 9. Feb 2017, 18:58
Wohnort: Bendorf / München
Kontaktdaten:

Re: Software für Raspberry mit TPUART Modul

Beitrag von ZwergNase »

Bei mir läuft das TPUART-Interface mit knxd und folgender ini-Datei:

Code: Alles auswählen

[A.tpuart]
debug = debug-A.tpuart
device = /dev/ttyKNX0
driver = tpuart
filters = log
[debug-A.tpuart]
error-level = 0x9
trace-mask = 0x3ff
[debug-server]
name = mcast:knxd
[main]
addr = 1.1.254
client-addrs = 1.1.250:8
connections = server,A.tpuart,server2
systemd = systemd
[server]
debug = debug-server
discover = true
router = router
server = ets_router
tunnel = tunnel
[server2]
server=knxd_tcp
Den Eintrag device = /dev/ttyKNX0 noch auf die verwendete Schnittstelle anpassen i.d.R. am RasPi /dev/ttyAMA0.

In der ETS wird das Interface dann ohne Einstellungen erkannt (bei mir zumindest, getestet mit ETS 4, 5 und 5.5)

Ich betreibe knxd in einem Docker-Container. Das läuft schon seit einigen Installationen schön rund. FHEM und Homebridge habe ich ebenfalls in Container gepackt.
Ich will schon die ganze Zeit eine Doku zur Installation zusammenstellen und hier oder im Wiki zur Verfügung stellen. Vielleicht mag das jemand mit mir zusammen machen?

Auf jeden Fall viel Erfolg,
Oliver
Oliver (ZwergNase)

RasPi 3 mit FT1.2 (ARM und LPC), TPUART, out8-bcu1 (ARM), out-cs-bim112, in8-bcu1 (230V, ARM), Drossel_2TE (nur für Testaufbau)
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Hallo zusammen.

Also das Image von der KNX-Forum Seite läuft nun und wird erkannt in ETS 5.5 :)
Der Fehler war wohl, dass ich nicht im selben Netzwerk war...

Ich habe Zuhause einen Repeater und der hat Wahrscheinlich ein Unternetzwerk ....
Das ist immer so eine Sache mit diesen Netzwerken...

Aber zum testen sollte es jetzt funktionieren hoffe ich.

Sehe ich das recht, dass eibd nicht mehr weiterentwickelt wird und ich eventuell besser knxd verwenden sollte?

Dann werde ich nämlich noch versuchen, mit den Tipps welche ihr mir vorher gegeben habt das Ganze mit knxd zum laufen zu bringen...

@Oliver: Eine Anleitung oder Doku zur Installation und Einrichtung wäre sehr schön 8-) ;)

Lg Michi ;)
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Hallo zusammen.

Nachdem ich heute ein wenig mit ETS programmieren wollte, habe ich leider ein weiteres Problem:

Das Interface wird zwar erkannt, aber ich habe die Adresse 0.0.0 und so wie ich nun im Internet gelesen habe, funktioniert das so nicht ich muss ja im gleichen Bereich sein oder?

Die Adresse kann ich unter ETS auch nicht änder, und ich wüsste nicht wie ich das im Raspi genau machen muss...

Wenn ich auch eine Adresse eines Gerätes programmieren möchte, dann erhalte ich immer folgende Fehlermeldung:
Schnittstellenmeldung:

Der Medientyp des aktuellen Subnetzes stimmt nicht überein mit dem Medientyp der Linie in Ihrem Projekt.
Möchten Sie Ihre lokalen Einstellungen nun ändern?
Linie: 0.0 Bereichslinie-IP
Schnittstelle: eibd on WireGate - 192.168.1.156:3671(0.0.0)-TP
Kann mir hier jemand weiterhelfen?


Lg und Gruss

Michi :)
Doumanix
Beiträge: 464
Registriert: 7. Nov 2017, 16:33

Re: Software für Raspberry mit TPUART Modul

Beitrag von Doumanix »

Hi Michi,

ich muss gestehen: hier habe ich einfach so weit gemacht, dass es geht.
Verstanden, warum diese Meldung immer kommt, hab ich allerdings nicht. Ich hab am Anfang hin und her probiert mit TP und was weiß ich was ... Jetzt läuft es aber schon seit über einem Jahr genau so, wie du es beschreibst bei mir ...

Klick mal einfach auf "beibehalten" ... ;)
Bei mir läuft dann immer alles sauber durch. :D

Grüße
Christian
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Das hatte ich bereits probiert, bringt allerdings leider nichts!

Der Balken Programmierung läuft, und läuft und läuft in der ETS und es passiert nichts weiter...

Kann ich irgendwie testen ob mein TPUART-Board richtig funktioniert? (obwohl das mit den wenigen Bauteilen eigentlich passen sollte...)
Da irgendwas messen oder so?
Ich habe das Gefühl, dass vielleicht auch hier etwas nicht stimmen könnte...

Oder ob es doch nur an der richtigen Konfiguration liegt :roll: :?:


Lg Michi
Doumanix
Beiträge: 464
Registriert: 7. Nov 2017, 16:33

Re: Software für Raspberry mit TPUART Modul

Beitrag von Doumanix »

Hmmm ... eigentlich sollte der TP-UART ja das Einsteigen so leicht wie möglich machen. Da das TP-UART Modul von der ETS erkannt wird (und nicht immer wieder verschwindet, oder??), denke ich, dass das sauber funktioniert.

Es gibt Berichte, dass da manchmal die Spannung zusammenbricht. Tontechniker hatte ja im Wiki das Problem mit der v1.0 beschrieben. Dabei geht immer wieder die KNX Power LED aus / flackert. Behoben haben wir das, in dem ein 47k statt eines 4,7k Widerstandes verwendet wird.

Bei der Platine von GeminiServer kommt das übrigens auch manchmal vor, vor allem wenn die TX / RX LEDs bestückst sind. Da könnte ein R470 statt eines R330 helfen. Oder die LEDs einfach weg machen.

Aber wie gesagt: wenn die ETS stabil dein interface unter 0.0.0 anzeigt, sollte das nicht das Problem sein.
Ich würde eher am Gerät anfangen.
Welches Gerät ist denn dein erstes, das du programmieren willst? Blöde frage: leuchtet denn die Prog-LED? :?

LG
Christian
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Also die Power LED leuchtet nur gaaanz schwach... Da wollte ich sowiso einmal noch nachmessen, ob ich hier vielleicht den falschen Widerstand erwischt habe ...

Eine Prog LED gibt es ja auf den Platine von GeminiServer meines Wissens nach nicht oder?

Ja das Interface wird in der ETS stabil unter 0.0.0 angezeigt!

Das würde ja aber auch gehen wenn das TPUART einen Fehler hat denke ich oder?
Denn das hat ja mit der Software auf dem Raspi und nicht mit der Hardware zu tun :roll:

Grade getestet: Das Interface wird mir auch ohne eingestecktes TPUART Modul in ETS angezeigt...


Ich möchte den MDT Smart 86 Taster programmieren. Eine Prog LED gibt es da nicht, aber es steht auf dem Display Prog Mode das sollte also passen denke ich ...


Lg Michi
Doumanix
Beiträge: 464
Registriert: 7. Nov 2017, 16:33

Re: Software für Raspberry mit TPUART Modul

Beitrag von Doumanix »

Also ganz schwach ist OK.
Aber gaaaaanz schwach klingt doof. :-)

Theorie: du hast die Tantalkondensatoren falsch rum eingebaut. Prüf mal bitte: der Strich heißt bei denen, dass auf der Seite der Pluspol ist.

Wenn du das ausschließen kannst: ein gutes Foto hat schon so manches mal geholfen.
Antworten