Software für Raspberry mit TPUART Modul

Fragen und Diskussionen zu den Geräten. Sowohl Hardware als auch Software. English is welcome.
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Okay, ich muss das morgen mal noch genauer nachmessen...

Unter diesem Link habe ich ein paar Bilder der Platine. Vielleicht siehst du ja was das dir grade auffällt.
Nicht wundern dass die so glänzt, ich überziehe Sie nach dem Löten und reinigen immer mit Plastiklack zum Schutz.

Was ich jetzt gesehen habe bei genauerer Betrachtung, dass der eine Optokoppler keine runde Einkerbung hat (das markiert ja immer Pin 1) ich bin aber von der Beschriftung ausgegangen und beim anderen ist der runde Kreis vorhanden.
Das sollte eigentlich stimmen, die müssen ja seitenverkehrt montiert sein.

LG Michi

Tags:
Doumanix
Beiträge: 469
Registriert: 7. Nov 2017, 16:33

Re: Software für Raspberry mit TPUART Modul

Beitrag von Doumanix »

Nachdem das mein Bausatz sein dürfte: also es sollten schon beide Optokoller die MArkierung für Pin 1 haben.
Die Tantal sehen gut aus.
Was mir auffällt: die Stifte für die KNX Klemme gehören für die Variante, dass seitlich angeschlossen werden soll nach unten. Damit fungieren sie auch as Abstandshalter auf dem RPi ... Wenn du sie so anschließen willst, müsstest du die Klemme so drehen, dass die Kabel nach innen gehen. Oder die Seiten vertauschen.

Ja, eine Messung, wie viel Volt jeweils anliegen wäre interessant...
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Hmm da ist irgendwo echt der Wurm drin glaube ich ...

Ich werde bei Gelegenheit noch messen, ob ich beim Raspi ein Signal habe wenn ich in der ETS auf Programmierung klicke und ob ich ein Signal auf dem KNX-BUS sehe...

Und sonst weis ich dann echt nicht mehr weiter.

Ich bin mir nicht sicher ob es am TPUART Modul oder an der Raspi Software liegt.


Lg Michi
suttermichi
Beiträge: 41
Registriert: 5. Apr 2019, 00:51

Re: Software für Raspberry mit TPUART Modul

Beitrag von suttermichi »

Hallo zusammen :)

Ein kurzes Update zu meinem Interface:

Ich habe mit zwergnase per Email versucht den Raspi richtig aufzusetzen.
Dafür einmal vielen Dank!!
Es sieht nun so aus als ob der TPUART defekt ist weil der knxd Dienst auf dem Raspi gleich wieder quittiert wird nach dem Start, weil da keine Antwort kommt ...

Ich versuche das möglichst bald mal zu messen, habe aber Momentan fast keine Zeit.


Für den Moment und damit ich jetzt nicht komplett stehe, habe ich mir ein gebrauchtes Interface zugelegt.

Mit dem funktioniert bis jetzt alles wunderbar ;)

Ich möchte jetzt dann, sobald die Zeit vorhanden ist, einmal mit den Selfbus Komponenten starten...!

Wegen dem Interface schaue ich dann natürlich auch nochmal.

Lg Michi
Doumanix
Beiträge: 469
Registriert: 7. Nov 2017, 16:33

Re: Software für Raspberry mit TPUART Modul

Beitrag von Doumanix »

Hi Michi,

ich hab mir das ganze nochmal angesehen.
Ich bin der Meinung, dass du die beiden Tantal vertauscht hast. Der TPUART-IC sollte also schon funktionieren. Hoffe, du hast den noch nicht in die Tonne gekloppt.

Ja, auch auf GeminiServers Fotos ist das so wie bei dir (@GeminiServer: das ist doch ein Fehler, oder??). Aber auf meinen kürzlich nachbestellten PCBs und in der Schaltung steht eindeutig, dass + von C3 (6,8µF) auf den 47k Widerstand geht. Und das ist sowohl bei deiner Version des PCB so als auch auf der, die im Git eingecheckt ist.

Gruß
Christian
Tontechniker
Beiträge: 264
Registriert: 25. Mai 2013, 09:49
Wohnort: Melsungen/Hessen

Re: Software für Raspberry mit TPUART Modul

Beitrag von Tontechniker »

Hallo Michi und Christian,
die "+" - Seite des 100uF Tantal muß an Punkt 9 und über 47nF an Punkt 8 des TPUART gehen. Ist das nicht der Fall, kann die Schaltung nicht arbeiten (6,8uF ist mit 100uF vertauscht).
Gruß
Hans
Antworten