BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Fragen und Diskussionen zur Entwicklung von neuen Geräten. Sowohl Hardware als auch Software. English is welcome.
Darthyson
Beiträge: 24
Registriert: 3. Sep 2020, 14:03

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von Darthyson »

Hallo Stefan,

find ich gut, dass du mir zustimmst, allerdings wäre es nicht schlecht, wenn noch jemand anderes das selbe Problem hätte ;), bisher schein ich der einzige zu sein.

Daher nochmal mein Aufruf, wer BIM112 Geräte einsetzt bitte testen, und falls das Problem nicht auftritt, bitte auch berichten incl. ETS Version.

Viele Grüße
Denis
ETS 5.7.4 (Build 1093), Gira IP-Router 103000, MCUXpresso IDE v11.3.0 [Build 5222], Windows 10 Version 2004
3x in16-bim112 ARM | 2x rol-jal-bim112 ARM | 8x Kombisensor LPC | 1x out8 LPC | 2x 2in2out LPC | 2x 8IN LPC

uwe223
Beiträge: 31
Registriert: 26. Sep 2015, 10:56

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von uwe223 »

Hallo Denis,

ich habe mal mit 2 Stück out6-cs-bim112 und der ETS 5.7.2 Build743 getestet und da tritt das Problem nicht auf.
Das sind jedoch ABB-Produktdatenbanken.

Gruß
Uwe

Darthyson
Beiträge: 24
Registriert: 3. Sep 2020, 14:03

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von Darthyson »

Hallo Uwe,

danke fürs testen.
Hatte jetzt mal endlich etwas Zeit und es auch mit der out-cs-bim112 getestet, auch damit habe ich das selbe Problem. Nun weiß ich auch nicht mehr was die Ursache sein könnte...

Viele Grüße
Denis
ETS 5.7.4 (Build 1093), Gira IP-Router 103000, MCUXpresso IDE v11.3.0 [Build 5222], Windows 10 Version 2004
3x in16-bim112 ARM | 2x rol-jal-bim112 ARM | 8x Kombisensor LPC | 1x out8 LPC | 2x 2in2out LPC | 2x 8IN LPC

Darthyson
Beiträge: 24
Registriert: 3. Sep 2020, 14:03

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von Darthyson »

Hallo Uwe,

kurze Nachfrage:
Bei deinem Test mit der out6-cs-bim112, hattest du da auf beiden Controller-Platinen den selben ARM LPC111x-Typen drauf?

Grüße
Denis
ETS 5.7.4 (Build 1093), Gira IP-Router 103000, MCUXpresso IDE v11.3.0 [Build 5222], Windows 10 Version 2004
3x in16-bim112 ARM | 2x rol-jal-bim112 ARM | 8x Kombisensor LPC | 1x out8 LPC | 2x 2in2out LPC | 2x 8IN LPC

Doumanix
Beiträge: 379
Registriert: 7. Nov 2017, 16:33

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von Doumanix »

Für alle, die sich ggf. bereits die ETS >= 5.7 drauf gebügelt haben und nun das in dem Thread hier beschriebene Problem haben: hier gibt's nochmal offiziell die 5.6.6: https://knxcloud.org/index.php/s/WSSw59U5gJsQHvu

Bin ich darüber drauf gekommen: https://forum.timberwolf.io/viewtopic.php?t=643

Hendrik
Beiträge: 166
Registriert: 3. Aug 2015, 15:16
Wohnort: Heidelberg

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von Hendrik »

Hallo Denis,

ich kann das Problem mit zwei in16-bim112 auf TS-ARM und ETS 5.7.3 nachvollziehen. Kannst Du mir Deinen Patch mal geben, bitte?

Viele Grüße,
Hendrik

Darthyson
Beiträge: 24
Registriert: 3. Sep 2020, 14:03

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von Darthyson »

Hallo Hendrik,

hab bisher erfolglos versucht meine 4 commits in eine .patch Datei zu bekommen.
Daher hier erstmal die commits als 4 separate .patch Dateien.
Sollte es damit Probleme geben, einfach nochmal melden.

Viele Grüße
Denis
Dateianhänge
BIM112_flag_patch.zip
(6.39 KiB) 2-mal heruntergeladen
ETS 5.7.4 (Build 1093), Gira IP-Router 103000, MCUXpresso IDE v11.3.0 [Build 5222], Windows 10 Version 2004
3x in16-bim112 ARM | 2x rol-jal-bim112 ARM | 8x Kombisensor LPC | 1x out8 LPC | 2x 2in2out LPC | 2x 8IN LPC

Hendrik
Beiträge: 166
Registriert: 3. Aug 2015, 15:16
Wohnort: Heidelberg

Re: BIM112 Geräte verlieren die ETS-Programmierstatus Flags

Beitrag von Hendrik »

Hallo Denis,

mit Deinem Patch tritt das Problem bei mir nicht mehr auf.

Vielen Dank und viele Grüße,

Hendrik

Antworten