Probleme Programmierung mit Raspberry PI

Hier geht es um Programme die auf "normalen" Computern laufen, also keinen Mikrokontrollern: eibd, Visus, Raspberry-PI, Linux, Entwicklungsumgebungen, etc. English is welcome.
Antworten
Gitarrenflo
Beiträge: 14
Registriert: 31. Jul 2013, 19:40

Probleme Programmierung mit Raspberry PI

Beitrag von Gitarrenflo »

Hallo,

ich habe den "FT1.2 Adapter für Raspberry Pi". Leider funktioniert die Programmierung nicht richtig. Folgendes Problem:
Inbetriebnahme>Programmieren>Applikationsprogramm mit der ETS4 läuft richtig an. Beim Schritt "Gerät programmieren..." bricht er kurz vor Schluss ab (grüner Balken) und bringt diese Fehlermeldung:
Programmieren(Appl.): Fehlgeschlagen
Das Gerät mit der phys. Adresse %1 kann nicht gefunden werden.

oder
Programmieren(Appl.): Fehlgeschlagen
Das Gerät antwortet nicht.

Über Gruppenmonitor kann ich allerdings auf den Bus schauen. Funktioniert!

Auf dem Raspberry habe ich Smartvisu-Image laufen.
mein Eintrag bei etc/default/eibd:

#EIB_ARGS="--daemon --Server --Tunnelling --Discovery --GroupCache --listen-tcp"
#EIB_ADDR="0.0.1"
#EIB_IF="tpuarts:/dev/ttyAMA0"
#EIB_UID="smarthome"

#EIB_IF="ipt:192.168.2.30"
#EIB_UID="1000"


#PI FT1.2
#EIB_ARGS="--daemon --Server --Tunnelling --Discovery --GroupCache --listen-tcp --no-tunnel-client-queuing"
EIB_ARGS="--daemon --Server --Tunnelling --Discovery --GroupCache --listen-tcp"
EIB_ADDR="0.0.1"
EIB_IF="ft12:/dev/ttyAMA0"


Habt Ihr eine Idee woran dies liegen könnte?

Gruß
Flo

Tontechniker
Beiträge: 248
Registriert: 25. Mai 2013, 09:49
Wohnort: Melsungen/Hessen

Re: Probleme Programmierung mit Raspberry PI

Beitrag von Tontechniker »

Hallo Flo,
habe die gleichen Einstellungen - bei mir läuft es.
Mein Angebot steht. Ich überprüfe dein Interface gern auf Funktion (keine Kosten - außer benötigtem Material). Bei mir funktionieren auch nicht alle Geräte. Probleme habe ich mit einem "Info-Display UP" V2.0 von Merten (steckt auf IF 6101/1.0). Das Gerät kann ich nur mit einem "gekauften" USB-Interface über den Bus programmieren (vermutlich Timing-Problem mit FT1.2 FW).
Gruß
Hans

Antworten