knxd und FT1.2

Hier geht es um Programme die auf "normalen" Computern laufen, also keinen Mikrokontrollern: eibd, Visus, Raspberry-PI, Linux, Entwicklungsumgebungen, etc. English is welcome.
Marcel
Beiträge: 6
Registriert: 30. Nov 2016, 22:09

knxd und FT1.2

Beitrag von Marcel »

Hallo zusammen!

Ich bin neu hier im Forum und finde Euer Engagement und KnowHow wirklich super!
Daher habe ich mir direkt das FT1.2-Hat nachgebaut und es an einem RPi B mit installiertem eibd erfolgreich in Betrieb genommen.

An meinem RPi 3 bekomme ich die ganze Geschichte eben nicht zum Laufen.
Mein Setup sieht folgendermaßen aus:

- RPi 3 mit FT1.2-Hat und installiertem Jessie
- Selfbus 8-fach Binärausgang (auch erfolgreich getestet)
- Merten verdrosselte Spannungsversorgung

Ich bekomme es trotz overlay des UART nicht hin, dass meine ETS auf den Bus zugreifen kann. Ehrlich gesagt, bin ich mit der Konfiguration des knxd total überfordert, denn es scheint mir als müsse ich irgendwo angeben, dass ich als Schnittstelle "/dev/ttyAMA0" nutzen möchte - nur wo??

Wie gesagt, rein von der Hardware läuft das Setup tadellos, aber softwareseitig ist irgendwo der Wurm drin und ich hoffe, jemand von Euch weiß Rat. :)

Bevor ich planlos irgendwelche *.config oder *.log files poste, lasst mich doch bitte wissen, was Ihr braucht, dann liefere ich es nach.

Vielen Dank!

Mirko
Beiträge: 104
Registriert: 13. Feb 2015, 15:41

Re: knxd und FT1.2

Beitrag von Mirko »


Marcel
Beiträge: 6
Registriert: 30. Nov 2016, 22:09

Re: knxd und FT1.2

Beitrag von Marcel »

Danke für Deine schnelle Antwort!

Ich habe den Rat befolgt, meine knxd.conf sieht jetzt so aus, wie es dort steht.

Wenn ich den Status des Service' abfrage bekomme ich:

Code: Alles auswählen

~ $ /etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Thu 2016-12-01 08:21:56 UTC; 2s ago
  Process: 882 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
 Main PID: 882 (code=exited, status=1/FAILURE)

Werner
Beiträge: 92
Registriert: 19. Apr 2015, 20:55

Re: knxd und FT1.2

Beitrag von Werner »

Achtung Falle!

Beim RPi 3 ist die serielle Schnittstelle standardmäßig durch Bluetooth belegt! TxD und RxD liegen auf anderen Pins - und die Baudrate ist nicht stabil!

Lösung: Bluetooth in der /boot/config.txt deaktivieren!

Code: Alles auswählen

dtoverlay=pi3-disable-bt
enable_uart=1
Mittlerweile ist das einigermaßen bekannt. Mich hatte es zu Anfangszeiten des RPi3 einiges an Zeit gekostet das herauszufinden...

StefanT
Beiträge: 268
Registriert: 17. Mai 2013, 08:18
Wohnort: Salzburg

Re: knxd und FT1.2

Beitrag von StefanT »

Ein guter Hinweis, danke!

Ich habe es im Wiki auf der Seite Anpassen eines Raspbian Image an den RPi Bus Controller eingetragen.

Marcel
Beiträge: 6
Registriert: 30. Nov 2016, 22:09

Re: knxd und FT1.2

Beitrag von Marcel »

Das ist auch schon geschehen, löst das Problem leider trotzdem nicht.

Marcel
Beiträge: 6
Registriert: 30. Nov 2016, 22:09

Re: knxd und FT1.2

Beitrag von Marcel »

So, ich habe das Gateway jetzt mithilfe dieser Seite zum Laufen bekommen

https://sourceforge.net/p/smarthomeng-r ... wiki/knxd/

Die ETS (3) erkennt das Gateway, aber das war's dann leider auch. Ich bekomme keinen Buszugriff :cry:
Langsam bin ich echt am verzweifeln...

StefanT
Beiträge: 268
Registriert: 17. Mai 2013, 08:18
Wohnort: Salzburg

Re: knxd und FT1.2

Beitrag von StefanT »

Kann es sein dass der knxd keine Verbindung zur FT1.2 hat?
Meines Wissens prüft die ETS nur ob sie zum knxd kommt - ich kann mich aber irren ;-)

oldcoolman
Beiträge: 645
Registriert: 17. Mai 2013, 20:57
Kontaktdaten:

Re: knxd und FT1.2

Beitrag von oldcoolman »

Genau. Wenn man zum Bsp 5R6 mit 5k6 auf der Raspi HAT vertauscht, denkt ETS alles ist gut. Es kommt aber nicht zur Verbindung mit einem Gerät.
liebe Grüße
Andreas

Marcel
Beiträge: 6
Registriert: 30. Nov 2016, 22:09

Re: knxd und FT1.2

Beitrag von Marcel »

Allem Anschein nach ist es genau so - die ETS hat Verbindung zum knxd, aber letzterer hat keine Verbindung zum Bus. Auch der manuelle

Code: Alles auswählen

groupswrite
über bash bringt keinen Erfolg.

Das kuriose daran ist, dass das RasPi Hat bereits lief (s.o.). Huckepack auf einem RasPi B konnte ich munter auf den Bus funken und meine 8-fach Ausgangsbaugruppe schalten lassen. Also lassen sich falsch platzierte Widerstände erstmal aussschließen.

Ich denke, dass das Problem wirklich zwischen knxd und FT1.2 liegt. Aber ich habe leider keine Ahnung, wie die richtige config aussehen muss :lol: Ich finde mich im wiki auf GitHub von knxd leider nicht so gut zurecht, als dass ich dort des Rätsels Lösung finden könnte...
Fakt ist, dass meine serielle Schnittstelle genau da liegt, wo sie liegen soll. Onboard BT ist deaktiviert und ttyAMA0 ist frei für I/O.

Hat evtl. jemand das Hat auf einem RasPi 3 am laufen und wäre so nett, mir seine/ihre config oder gar ein Image zur Verfügung zu stellen? :)

Antworten